Client Documents and Attachments



Objective: Learn how to create document templates, upload attachments and create client documents.

NEW Probatum Editor VS HTML Editor


Previously in Probatum, all document templates and client documents were created using a simple HTML web editor. While the HTML editor handled most document needs, a more robust downloadable editor was created in order to mimic the familiar experience of a word processing software. 

Both text editors are currently available in Probatum in order to maintain legacy templates and client documents. Additionally, the Probatum Editor can only be downloaded onto a Windows PC. A document that was created using an HTML template can only be opened in the HTML editor. Likewise, a document that was created using the Probatum Editor template can only be opened and edited using the Probatum editor. Because of this, it is highly recommended that an organization choose to standardize their documents using one editor or the other.

The following tutorials will walk through template creation and creation of new client documents using both editors.

Accessing Document Templates


To access Document Templates:

  1. Click the Apps menu (found on the toolbar at the top of the Home screen).   

  2. Select Organization Management.

  3. You will notice the setup options grouped by category.  Click Templates in the Document setup section to open the template list.




Creating a New Document Template


In Probatum, there are two main types of documents, merged client documents and uploaded attachments. Documents can be generated once an administrator has created the Document Templates. When a user merges a document template with a client's unique data, a new document is created. This is further explained in the Creating A New Document section. 

Document templates help to ensure that your organization's documents are uniform from client to client. When a template is created, you can add place holders for client specific information. The following tutorials give a brief explanation of how to configure a document template and how these place holders work.

Creating Templates in the Probatum Editor


This editor can only be accessed on a Windows PC. If you do not have a Windows PC or anticipate editing documents on any platform other than Windows, consider using the HTML editor for your documents.


  1. To add a new document template, click the "Add New" button in the bottom right corner of the screen from the template list.  

  2. Select Editor Template

  3. The Template Edit view will open. Enter the template name and Additional Info

  4. You can mark the template active when you are ready for it to be available to create client documents. You can leave this unchecked for now if you wish and click active once you have finished creating the template.

  5. Click the checkmark icon to save the template info before launching the editor. 

  6. If using the Probatum editor for the first time in Chrome, you will need to follow the instructions on your screen and install the ClickOnce Launcher browser extension. This will only need to be done once. 

  7. Click "Launch Probatum Editor". The editor will download onto your PC or launch if already downloaded.

  8. Once the editor opens, you will notice a blue toolbar with the following menus: File, Home, Insert, Page Layout, References, Data Merge, and View. You can see all the various text and paragraph options available by clicking through the various menus in the toolbar. 

  9. Click Data Merge in the toolbar. You will see a button labeled "Insert Merge Field". Clicking on any of the items from the list will insert a placeholder that will be merged with the corresponding client/case information when a document is created. For example, the placeholder may appear as <<ClientNameFull>> in the form template, but when a client document is created, it will appear with the actual client name.

  10. Once you are satisfied with your template, save it by clicking "Save to Probatum" under the file menu.

  11. You may now close the Probatum Editor.

Creating Templates in the HTML Editor

  1. To add a new document template, click the "Add New" button in the bottom right corner of the screen from the template list.  

  2. Select <HTML> Template

  3. The Template Edit view will open. Enter the template name and description.



  4. Click the checkmark icon the save the template name and description. 

  5. After saving, click Open HTML Editor.

  6. When the document opens, click anywhere on the page to open the editor toolbar. Use the editor to customize the layout and text of the form. 



  7. To enter a customizable field into the editor, click the Token icon in the toolbar. 



  8. Choose an item from the Token Insertion drop down (i.e. Client Full Name, Birth Date, Case Supervisor, etc.). 



    This will insert a placeholder that will be merged with the corresponding client/case information when a document is created. For example, the placeholder may appear as {{client_name_full}} in the form template, but when a client document is created, it will appear with the actual client name.


  9. When you make edits to the document template, you will notice an alert icon in the toolbar at the top of the screen that means "Changes detected". This will notify you if the template has unsaved edits.  

  10. To save, click the checkmark icon in the toolbar at the top of the screen.  

  11. When you are satisfied with your changes and wish to print OR if you simply want to view the document as a PDF, click the Preview button in the bottom right corner of the screen. It is recommended that you preview the template as a PDF to make sure you are satisfied the look and feel of the printed version of the template BEFORE creating a merged client document. 


  12. The PDF Preview will display a new toolbar at the top of the screen. This toolbar contains controls for the PDF. From left to right, these icons allow you to: close the preview and return to the editor, zoom in, zoom out, page up, page down, and print the document. 


Using the HTML Editor


There are a few items to note when using the HTML editor. When creating a document, you may notice that the placement of your text seems to be different in the editor than in the PDF preview. For instance, you may type 2 lines of text in the editor, but when printed, it displays as 3 lines. This is because the page size is not defined until the document is converted to PDF. This is good to keep in mind as you create your templates. While sometimes it may make sense to simply use multiple spaces to move text to a specific part of the page, we strongly recommend the usage of Tables to position text. This will be covered more in depth in the "Utilizing Tables" section below. Below are a few more items to note regarding the usage of the editor.

Margins

The documents are created to have a default setting of 0.5in. margins. When you are creating a template, there is no need to worry about margins, since they are already defined. You may notice as you type in the editor, that the text seems to be spanning far across the page, but, as stated above, the printed PDF will define the page size and set the margins.

Font Size

The documents are created to have a default setting of 10pt font. You can change the font size, by selecting the entire document text, and choosing a different font size. 

Pasting Content from Another Document

While you can copy and paste content from other documents into your template, we strongly recommend using the "Paste as Plain Text" feature. When text is copied from a document, the text formatting is also copied. While this may seem ideal at times, it can create unwanted formatting. When you click the "Paste as Plain Text" icon (    ), a window will open and you can simply paste the text content there. This will remove existing formatting and allow you to style the text once it has been pasted into the document. 

Utilizing Tables in the HTML editor

Tables are a very useful tool when creating templates for frequently used forms and documents. They are a great way to position text to ensure that it always looks good when printed. For example, you may wish to add some text to a document, but you want it to be on the right half of the page instead of the left. You can achieve this by creating a simple table with 2 columns, and set each column width to 50%. Here are a few tips on how to utilize tables to create a clean, polished document.

  1. Click the Insert Table icon in the editor and use the grid to select the number of rows and columns for the table. The example below shows what you would select to insert a table with 2 rows and 4 columns. 


     
  2. Once the table has been created, you can further customize it by right clicking the table and selecting Table Properties.



  3. The Table Properties dialogue box will open. Each item of the table properties will be addressed below.


     

    WIDTH AND HEIGHT: It is strongly recommend that you leave the width at 100% in order for the table to stretch the width of the page. This is very important. The appearance of the document in your web browser may be slightly different from its appearance when printed. Leaving the height blank will allow the table to grow in height as you add text. 

    Setting a pixel value that appears to span the width of the page may cause some of your text to be cut off when printing if the table is too wide. However, setting a 100% width will solve this problem, because it always guarantees that the table spans the entire width of the page without being too wide.



    HEADERS: If desired, define headers for the table. The header cell has bold text by default, as seen below. The table can be formatted to have header cells along the first row or first column, or both.




    BORDER SIZE: Add a border value to the table. (The table pictured above has a 1px border applied.) If you set the border to 0, the table will appear in the editor with a faint dotted line around the table cells. This is merely for reference as you edit; no lines will appear when the document is printed.
     
    ALIGNMENT: Set the alignment of the text in the table cells to be left, right, or center. (Text in the header cells will center by default, but this can be changed by using the align icons in the editor's toolbar.)
     
    CELL SPACING AND PADDING: Set cell spacing and cell padding for the table. Cell spacing refers to the space between each table cell. Cell padding refers to the space between the content inside a cell and the wall of the cell. Examples are provided below.

    *This table has a cell spacing of 4 and a cell padding of 0. Notice the 4px space is between the table cells, and not within the table cells.
        

    *This table has a cell spacing of 0 and a cell padding of 4. Notice the 4px space is within the table cells (separating the text from the wall of the cell), and not between the table cells.


    *This table has a cell spacing of 0 and a cell padding of 0. Notice how crowded the table appears.

     

  4. When you are finished with the Table Properties, click OK.
     
  5. You may edit the table or table cells at anytime by right clicking on the table. Here you can delete the table, add rows or columns, edit the table/cell properties, or split cells. The options below will display when hovering over the Cell option in the first menu.
     

    Below are some examples of split cells. You may find it helpful to create a few tables and try this yourself.

    *This table was created with 2 rows and 1 column. However, the cell on the bottom row has been split horizontally. Now, there are 2 cells spanning the width of 1 column.


    *This table was created with 3 rows and 2 columns, However, the first cell of the first column has been split vertically. Now, there are 2 cells spanning the height of 1 row.



  6. You may notice that the columns in the table vary in widths, depending on how much content is in each cell. You can set a fixed width for the columns by right clicking on a cell and selecting "cell properties". The cell width can be set to a percentage value. Below is an example of a table with fixed cell widths.


 

Accessing Client Documents and Attachments


Client documents can be accessed from the client screen by clicking “Documents” on the side menu. Here you’ll find a list of both documents that have been created using the document templates, as well as various types of attachments that have been uploaded into Probatum. The document list displays the title of the files and the date each file was created or uploaded.





Creating a New Client Document


Once the organization administrator has created the document templates, users can quickly generate documents for their clients. Creating a client document merges the client's unique personal data or case data with the document template.

  1. From the Documents and Attachments list, click the “Add New” button in the bottom right corner.

  2. Select Create New Doc.



  3. A dialog will open with prompting you to select the document template you wish to use. The template type will display beside the template name signifying whether it is an HTML or DOC template.




  4. If you are using an HTML template and it requires case data to be merged, select the appropriate case from the drop down menu.

  5. Click Continue.

  6. Here, you can edit the name of the document, as well as tag cases. Simply start typing the Case ID, and select the correct case when it appears in the list. Click the X beside the case if you wish to remove the tag.



  7. If the template is a DOC template and you are using the Probatum editor for the first time in Chrome, you will need to follow the instructions on your screen and install the ClickOnce Launcher browser extension. This will only need to be done once. If this is an HTML template, simply move to the next step.

  8. Click Open Editor.

Editing a Client Document in the Probatum Editor

  1. If a document template contains merge fields that require case data, you will be prompted to select the case by navigating to the Data Merge tab on the blue toolbar. From there, use the Next/Previous Case buttons to select the appropriate case. 

  2. Make any desired edits to the document.

  3. When you are satisfied with your changes, open the File tab in the blue toolbar and click Save to Probatum.

  4. From the File tab, you may also Print the document. 

Editing a Client Document in the HTML Editor

  1. The document will open in the text editor. Notice that the tokens that were inserted in the document template have now been populated with the client's unique information. 

  2. If you wish to make edits to the document, simply click anywhere in the document and the editor toolbar will appear.For more information about using the document editor to customize the document, see the "Using the Document Editor" tutorial above.



  3. When you make edits to the document, you will notice an alert icon in the top toolbar that means "Changes detected". This will notify you if the document has unsaved edits. 

  4. To save, click the checkmark icon in the toolbar at the top of the screen. 

  5. When you are satisfied with your changes and wish to print OR if you simply want to view the document as a PDF, click the Preview button in the bottom right corner of the screen. 

  6. The document will then be converted to a PDF and allow you to preview before print. The PDF Preview will display a new toolbar at the top of the screen. This toolbar contains controls for the PDF. From left to right, these icons allow you to:close the preview and return to the editor,zoom in, zoom out, page up, page down, and print the document. If you are satisfied with the appearance and format of the document, click the print icon in your PDF viewer. 



  7. If you are not satisfied with the PDF and wish to make changes before printing, click the X in the toolbar to close the print preview and return to the document editor.


Uploading an Attachment


  1. From the Documents and Attachments list, click the “Add New” button in the bottom right corner.

  2. Select Upload File.

  3. When the edit view opens, click Select File.

  4. Choose the file you wish to upload from your local directory. Supported files include:

    .pdf
    .tiff
    .docx

  5. Enter a Name for the attachment.

  6. If you are satisfied with your entry, click the checkmark icon in the toolbar to save the record.

    If you wish to close the edit view without saving, click the x in the toolbar to cancel your changes and return to the previous screen.




On this page: